BUG Community

Welcome! Log In

Forums BUGmodules I2C Bus

Subscribe to I2C Bus  2 posts, 2 voices

Log in to reply to this topic
 
Feb 10, 2009 7:33pm
Img_missing_medium lltdl7 7 posts

I see that, on the VonHippel, there are ports for I2C communication. However, I was unable to identify any way of using these with the SDK. Is it not implemented yet, or am I just missing it? If it isn’t there, is there any current plans on making it available? Thanks!

Feb 11, 2009 11:47am
Medium Bug Labs team kschultz 107 posts

The API is evolving for the VonHippel so there is a lot more functionality in the new version. The production version of the file system that has been vetted for problems and most likely shipped on your BUG is 1.3. The new version coming out right now is 1.4. We’re on build 1.4.5 or 1.4.6 I believe, and it definately has some changes to the Von Hippel API.

Switching the update site in your SDK install to http://buglabs.net/sdk/testing/current/updatesite/ will make your SDK switch to the newest version that has those APIs. Then you have to update your BUG root file system image as well. If I were you, I would update my SDK now and play with the new API, but wait a few days to put the new filesystem on your BUG. We are close to the actual production release and it is a bit more time consuming to flash the kernel and the SD card than to just update your Eclipse install.

If you join our mailing list you will get updates or watch this page: http://bugcommunity.com/wiki/index.php/Latest_B…, when it has 1.4 it will be production tested. I don’t have a link for the mailing list off the top of my head right now, but it is linked through the Wiki.

Log in to reply to this topic
Forums BUGmodules I2C Bus

Powered by Community Engine