BUG Community

Welcome! Log In

Forums BUGbase Hardware Issue?

Subscribe to Hardware Issue?  10 posts, 4 voices

Log in to reply to this topic
 
Dec 7, 2008 8:19pm
Img_missing_medium lltdl7 7 posts

I’m a senior computer engineering student at ONU. My senior design group had planned on doing a prototype of our project using the Bug. The problem is that we cannot get certain applications to run. We have tried simple ones like NightRider and that one works fine, but ones like GpsLogger will not work at all. Every time we start the BugBase, it just loads into a Linux OS. Sometimes the front display doesn’t even show that there are any modules attached. Other times when we remove a module, it still shows in the display until the Bug is restarted. Furthermore, there are times when all that shows up on the LCD module is a white (blank) screen.

I have read that the LCD module only works in ports 1 and 3, so we use it there (although I have tested it in every port). What is going on with this? Are we not understanding something? Is there an easy way to fix it?

Any help will be greatly appreciated.

Dec 8, 2008 11:39am
Medium Bug Labs team agordon 74 posts

Hi, lltdl7.

Please make sure that your BUG is running the latest release versions of Dragonfly SDK, and the BUG kernel and rootfs. See http://buglabs.net/sdk and http://bugcommunity.com/wiki/index.php/Latest_B… for details.

Also, some of the more "cutting edge" apps may not run without our upcoming 1.4 release, or without having other library apps installed. You can probably find all of these files in our subversion repository at svn.buglabs.net.

For GPSLogger, which version are you running? With version 1.1, I believe that you need to open up GpsLoggerApp.java, and find/replace all lines where "Latitude" is spelled as "Lattidue" to make the app work. These code errors are easy to find by following the breadcrumb trail of red "X"s in the Project Explorer in Eclipse, then looking for and clicking on the red blocks to the right of the scrollbar in the code editing screen.

Dec 8, 2008 11:40pm
Img_missing_medium lltdl7 7 posts

Sorry, the app I was trying to run was GPSLoggerSimpleGUI. I did try the other one though (after fixing the code errors) with no result. I tried putting on some simple GUI apps and they work fine.

The only time I seem to have a problem is when I’m trying to use the GPS. The screen displays like there should be something there – with the red bar and icons at the top, but with nothing else (the rest white).

I re-downloaded the SDK to no avail. Also, I’m pretty sure the Bug is up to date since I just received it on Friday. I’m really at a loss for what to do. Any other suggestions?

Dec 9, 2008 2:51pm
Medium Bug Labs team agordon 74 posts

Have you tried switching your BUGview display module to different slots on the BUG?

Dec 11, 2008 12:31am
Img_missing_medium lltdl7 7 posts

Yeah, we’ve tried it in every spot. That is another thing that is bothering us. I read that it only works in slot 1 and 3; for us it works in slot 3 just fine, however if we use it in slot 1, it is very touchy. It only works sometimes (haven’t figured out the circumstances that don’t allow it to work) and if it is even slightly bumped, it turns off as if it comes unplugged.

Dec 11, 2008 11:12am
Medium Bug Labs team finsprings 268 posts

lltdl7
The only time I seem to have a problem is when I'm trying to use the GPS. The screen displays like there should be something there - with the red bar and icons at the top, but with nothing else (the rest white)


IIRC, there's a problem where the GPS API can throw an exception if it's asked for data when there's currently no fix. I seem to remember having a similar problem with that app. I think it might get an exception that knocks it out of its function that's creating the Frame for display, so you end up with nothing.

Have you switched your GPS to use the external antenna (you can do that with an app like GPSConfig and selecting its "Use Ext Antenna" or add a call in GPSxxxGui to do it)? Its LED will be green if it has a fix and the BUGbase LCD will show fix:true in the menu for the GPS.
Dec 11, 2008 2:19pm
Medium jennyw 20 posts

Hi lltdl7,

This is Jenny from Bug Labs Customer Service. We’re really sorry that you’re having trouble with your BUGview LCD module, and we want to send you out a replacement ASAP.

Can you please send your contact info to support@buglabs.net as soon as you have a chance? I’ll make sure you get a new LCD post haste and will include a prepaid shipping label so you can return your existing one.

Thanks, and again, sorry for the hassle!

Jenny

Dec 12, 2008 2:35am
Img_missing_medium lltdl7 7 posts

Jenny,
Thanks a lot for the offer to replace the BUGview. It’s really great to see that BugLabs is actually interested in fixing problems.

However, I do not think that the BUGview is the problem. Any application that is run that only uses that module works fine. For example, the SimpleGUI and TipCalc work fine. The problems occur when any other module is attached. Also, the LCD only works 100% of the time in slot 3, but not in slot 1. We are still trying to figure out why. Do you think there could be a problem with the BugBase?

My group and I are going to thoroughly test finsprings’ solution to the GPS problem this weekend. We are currently waiting on the camera module (which should arrive in the next few days) and we will test that with some programs that people have said work.

Hopefully, by early next week I will have a full understanding of what circumstances will and wont work. I will do a detailed post about it at that time.

We just want to say thanks to everyone for the help you have given us so far!

Dec 13, 2008 9:42am
Medium Bug Labs team finsprings 268 posts

lltdl7
My group and I are going to thoroughly test finsprings' solution to the GPS problem this weekend.

Even with a fix, there still seems to be times when the NMEA parsing code gets update, so the problem is still being looked at. However if you wrap the GPS service calls in try/catch blocks and check returned data isn't null you should at least be able to see the GUI come up consistently regardless of whether you have a fix.

Regarding slots, in case it wasn't mentioned before, the base has two X displays running: one on slots 0/2 and the other on slots 1/3. Both are active but the Java virtual machine can only use one display or the other right now. By default the startup code for the Java virtual machine sets its DISPLAY to 0:1 which makes it come up on slots 1/3. If it helps in your testing you can edit the DISPLAY line in /usr/share/java/start.sh on your Bug to make it DISPLAY 0:0 and then restart the VM with /etc/init.d/concierge restart and it will use the display on slots 0/2 instead.
Jan 11, 2009 5:21pm
Img_missing_medium lltdl7 7 posts

Sorry for not updating this for a while – we have been on winter break and I didn’t have a working computer.

What we determined is that most of our problems stem from port 1. It only works sometimes. We have been using it for the LCD and in order to get it to work, we have to push the module in quite hard (much more force than the other ports). I suppose we can live with it.

The only other problem is that the VonHippel module is not recognized on start up. We have to remove it and re-insert it after boot. Still trying to figure out why that is. Any ideas?

Thanks for all of the help so far, we really appreciate it!

Log in to reply to this topic
Forums BUGbase Hardware Issue?