BUG Community

Welcome! Log In

Forums Applications Application don't get downloaded to device

Subscribe to Application don't get downloaded to device  17 posts, 4 voices

Log in to reply to this topic
 
Apr 19, 2009 2:35pm
User_img_not_found_03_med fiil123 14 posts

Hey fellow bug’ers

I have a bit of a problem with my bug, I can see it in me IDE and can also connect to it on 10.10.10.10 and even better I can also send the application to the BUG. But here the fun stops, I don’t get a error message but the application don’t show up on the bug. The application get’s downloaded (I think the bar moves so fast I can’t see anything) but again nothing is showing up on the device!

Hope somebody out there can help meJ

Cheers

Kenneth

Apr 20, 2009 4:05pm
Medium Bug Labs team agordon 74 posts

Hi, Kenneth.

Which application is this that you’re testing?  Are you sure that it’s not starting once it has been sent to your BUG?  If it’s an app that should display something on the LCD screen, try plugging the screen module into different ports on your BUG.

You may want to consider ssh’ing into your BUG and looking at the contents of /var/log/concierge.log, as well as maybe doing a directory listing of /usr/share/java/apps .  If that directory is empty, the app did not get uploaded to your BUG.  If there’s a file in there, perhaps try deleting it from the command line, and then re-send the app to the BUG again via the SDK.

You probably also want to make sure that your BUG is running with the latest kernel and rootfs images.  You can find those on the bottom of this page, in the “Files” area:  http://repo.buglabs.net/ .

Apr 21, 2009 1:16am
User_img_not_found_03_med fiil123 14 posts

Hey Agordon

 I have
attempted with the ”Hello World” test project and AppUI, AccelerometerVisualizer
and KnightRider from Community Applications. All with no luck, at this moment I’m
almost sure that the problem is that the application doesn’t get downloaded to the device! When
I get home from work today I will try your suggestion and report back about the
result.

K. Fiil

Apr 21, 2009 2:55am
Medium Bug Labs team kgilmer 215 posts

Hi fiil123,

  We experimented with different formats for sending apps to BUGs from version to version.  The downside to this is if you have a mismatched SDK and BUG, you’ll see errors when trying to install an app on the BUG.  The good news is that the latest pre-production release is smart enough to figure out what BUG version you have and send the app using the correct format.  If you haven’t already, please get the latest SDK version.  Here is the updatesite: http://buglabs.net/sdk/testing/1.3.1.v200904141…

thx
ken

Apr 21, 2009 4:05am
User_img_not_found_03_med fiil123 14 posts

Hej Ken

I think the
BUG I have could be a bit “old”, but the weird thing is that I don’t get an
error message when I download the application. It just completes with no success
or error message but the application just don’t seems to be on the device!

 K. Fiil

 

 

Apr 21, 2009 4:11am
Medium Bug Labs team kgilmer 215 posts

Can you paste here the contents of the /var/log/concierge file on your BUG?

Apr 21, 2009 4:29am
User_img_not_found_03_med fiil123 14 posts

Of cause I will do it when I get home to my BUG

Apr 21, 2009 4:28pm
User_img_not_found_03_med fiil123 14 posts

Hey Guys

Here is a log dump, it actually looks like it’s trying to start an old test application I have done called InnovationLabGui.jar wich results in an exception. I will try to delete that jar tomorrow and see if I can get one of the other applications running!

————————————————————————————
  Concierge OSGi 1.0.0.RC3 on Linux 2.6.24.4 starting …
————————————————————————————

Logger initialized, loglevel is DEBUG
purging storage …
INSTALLING service-tracker-1.0-rc3.jar
INSTALLING com.buglabs.osgi.shell-1.0.jar
INSTALLING com.buglabs.osgi.http-1.0.jar
INSTALLING com.buglabs.common-1.0.jar
INSTALLING ch.ethz.iks.slp-1.0.jar
INSTALLING com.buglabs.osgi.cm-1.0.jar
INSTALLING com.buglabs.bug.jni.common-1.0.jar
INSTALLING com.buglabs.bug.jni.input-1.0.jar
INSTALLING com.buglabs.bug.jni.audio-1.0.jar
INSTALLING com.buglabs.bug.jni.motion-1.0.jar
INSTALLING com.buglabs.bug.jni.accelerometer-1.0.jar
INSTALLING com.buglabs.bug.jni.basedisplay-1.0.jar
INSTALLING com.buglabs.bug.jni.gps-1.0.jar
INSTALLING com.buglabs.bug.jni.camera-1.0.jar
INSTALLING com.buglabs.bug.jni.bugbeep-1.0.jar
INSTALLING com.buglabs.bug.jni.lcd-1.0.jar
INSTALLING com.buglabs.bug.jni.vonhippel-1.0.jar
INSTALLING com.buglabs.bug.module.gps-1.0.jar
INSTALLING com.buglabs.bug.module.camera-1.0.jar
INSTALLING com.buglabs.bug.module.lcd-1.0.jar
INSTALLING com.buglabs.bug.module.motion-1.0.jar
INSTALLING com.buglabs.bug.module.vonhippel-1.0.jar
INSTALLING com.buglabs.nmea-1.0.jar
INSTALLING com.buglabs.bug.base-1.0.jar
INSTALLING com.buglabs.bug.menu-1.0.jar
INSTALLING com.buglabs.bug.service-1.0.jar
INSTALLING com.buglabs.bug.program-1.0.jar
INSTALLING com.buglabs.bug.module-1.0.jar
INSTALLING com.buglabs.bug.bmi-1.0.jar
INSTALLING com.buglabs.bug.event-1.0.jar
INSTALLING com.buglabs.bug.slp-1.0.jar
STARTING file:./service-tracker-1.0-rc3.jar
STARTING file:./com.buglabs.osgi.shell-1.0.jar
STARTING file:./com.buglabs.osgi.http-1.0.jar
STARTING file:./com.buglabs.common-1.0.jar
STARTING file:./ch.ethz.iks.slp-1.0.jar
Thu Jan 01 00:00:46 GMT 1970 jSLP OSGi started.
Thu Jan 01 00:00:47 GMT 1970 Debug outputs disabled
STARTING file:./com.buglabs.osgi.cm-1.0.jar
—More—(9% of 20514 bytes)
root@bug:#
root@bug:
# more /var/log/concierge.log
————————————————————————————
  Concierge OSGi 1.0.0.RC3 on Linux 2.6.24.4 starting …
————————————————————————————

Logger initialized, loglevel is DEBUG
purging storage …
INSTALLING service-tracker-1.0-rc3.jar
INSTALLING com.buglabs.osgi.shell-1.0.jar
INSTALLING com.buglabs.osgi.http-1.0.jar
INSTALLING com.buglabs.common-1.0.jar
INSTALLING ch.ethz.iks.slp-1.0.jar
INSTALLING com.buglabs.osgi.cm-1.0.jar
INSTALLING com.buglabs.bug.jni.common-1.0.jar
INSTALLING com.buglabs.bug.jni.input-1.0.jar
INSTALLING com.buglabs.bug.jni.audio-1.0.jar
INSTALLING com.buglabs.bug.jni.motion-1.0.jar
INSTALLING com.buglabs.bug.jni.accelerometer-1.0.jar
INSTALLING com.buglabs.bug.jni.basedisplay-1.0.jar
INSTALLING com.buglabs.bug.jni.gps-1.0.jar
INSTALLING com.buglabs.bug.jni.camera-1.0.jar
INSTALLING com.buglabs.bug.jni.bugbeep-1.0.jar
INSTALLING com.buglabs.bug.jni.lcd-1.0.jar
INSTALLING com.buglabs.bug.jni.vonhippel-1.0.jar
INSTALLING com.buglabs.bug.module.gps-1.0.jar
INSTALLING com.buglabs.bug.module.camera-1.0.jar
INSTALLING com.buglabs.bug.module.lcd-1.0.jar
INSTALLING com.buglabs.bug.module.motion-1.0.jar
INSTALLING com.buglabs.bug.module.vonhippel-1.0.jar
INSTALLING com.buglabs.nmea-1.0.jar
INSTALLING com.buglabs.bug.base-1.0.jar
INSTALLING com.buglabs.bug.menu-1.0.jar
INSTALLING com.buglabs.bug.service-1.0.jar
INSTALLING com.buglabs.bug.program-1.0.jar
INSTALLING com.buglabs.bug.module-1.0.jar
INSTALLING com.buglabs.bug.bmi-1.0.jar
INSTALLING com.buglabs.bug.event-1.0.jar
INSTALLING com.buglabs.bug.slp-1.0.jar
STARTING file:./service-tracker-1.0-rc3.jar
STARTING file:./com.buglabs.osgi.shell-1.0.jar
STARTING file:./com.buglabs.osgi.http-1.0.jar
STARTING file:./com.buglabs.common-1.0.jar
STARTING file:./ch.ethz.iks.slp-1.0.jar
Thu Jan 01 00:00:46 GMT 1970 jSLP OSGi started.
Thu Jan 01 00:00:47 GMT 1970 Debug outputs disabled
STARTING file:./com.buglabs.osgi.cm-1.0.jar
STARTING file:./com.buglabs.bug.jni.common-1.0.jar
STARTING file:./com.buglabs.bug.jni.input-1.0.jar
STARTING file:./com.buglabs.bug.jni.audio-1.0.jar
STARTING file:./com.buglabs.bug.jni.motion-1.0.jar
STARTING file:./com.buglabs.bug.jni.accelerometer-1.0.jar
STARTING file:./com.buglabs.bug.jni.basedisplay-1.0.jar
STARTING file:./com.buglabs.bug.jni.gps-1.0.jar
STARTING file:./com.buglabs.bug.jni.camera-1.0.jar
STARTING file:./com.buglabs.bug.jni.bugbeep-1.0.jar
STARTING file:./com.buglabs.bug.jni.lcd-1.0.jar
STARTING file:./com.buglabs.bug.jni.vonhippel-1.0.jar
STARTING file:./com.buglabs.bug.module.gps-1.0.jar
STARTING file:./com.buglabs.bug.module.camera-1.0.jar
STARTING file:./com.buglabs.bug.module.lcd-1.0.jar
STARTING file:./com.buglabs.bug.module.motion-1.0.jar
STARTING file:./com.buglabs.bug.module.vonhippel-1.0.jar
STARTING file:./com.buglabs.nmea-1.0.jar
STARTING file:./com.buglabs.bug.base-1.0.jar
STARTING file:./com.buglabs.bug.menu-1.0.jar
Thu Jan 01 00:00:50 GMT 1970 file:./com.buglabs.bug.base-1.0.jar  Tracking Service: com.buglabs.menu.IMenuProvider with implementation: com.buglabs.bug.menu.Menu@38f71fe
Thu Jan 01 00:00:50 GMT 1970 Tracker Complete.
STARTING file:./com.buglabs.bug.service-1.0.jar
Thu Jan 01 00:00:51 GMT 1970 file:./com.buglabs.bug.service-1.0.jar  Tracking Service: org.osgi.service.cm.ConfigurationAdmin with implementation: com.buglabs.osgi.cm.impl.ConfigurationAdminImpl@a8006c0a
Thu Jan 01 00:00:51 GMT 1970 Tracker unable to start because service com.buglabs.menu.IMenuProvider is unavailable.
Thu Jan 01 00:00:51 GMT 1970 file:./com.buglabs.bug.service-1.0.jar  Tracking Service: com.buglabs.menu.IMenuProvider with implementation: com.buglabs.bug.menu.Menu@38f71fe
Thu Jan 01 00:00:51 GMT 1970 Tracker Complete.
Thu Jan 01 00:00:51 GMT 1970 Registered servlet /service
Thu Jan 01 00:00:51 GMT 1970 Registered servlet at /service.
Thu Jan 01 00:00:51 GMT 1970 Registered resources /
STARTING file:./com.buglabs.bug.program-1.0.jar
Thu Jan 01 00:00:51 GMT 1970 file:./com.buglabs.bug.program-1.0.jar  Tracking Service: org.osgi.service.http.HttpService with implementation: com.buglabs.osgi.http.HttpServiceImpl@9f5f01a
Thu Jan 01 00:00:51 GMT 1970 Tracker unable to start because service org.osgi.service.cm.ConfigurationAdmin is unavailable.
Thu Jan 01 00:00:51 GMT 1970 file:./com.buglabs.bug.program-1.0.jar  Tracking Service: org.osgi.service.cm.ConfigurationAdmin with implementation: com.buglabs.osgi.cm.impl.ConfigurationAdminImpl@a8006c0a
Thu Jan 01 00:00:51 GMT 1970 Tracker unable to start because service com.buglabs.menu.IMenuProvider is unavailable.
Thu Jan 01 00:00:51 GMT 1970 file:./com.buglabs.bug.program-1.0.jar  Tracking Service: com.buglabs.menu.IMenuProvider with implementation: com.buglabs.bug.menu.Menu@38f71fe
Thu Jan 01 00:00:51 GMT 1970 Tracker Complete.
Thu Jan 01 00:00:51 GMT 1970 Using default directory for app storage: /usr/share/java/apps
Thu Jan 01 00:00:51 GMT 1970 AppManager checking /usr/share/java/apps/AccelerometerVisualizer.jar
Thu Jan 01 00:00:51 GMT 1970 Registered servlet /program
Thu Jan 01 00:00:51 GMT 1970 Registered servlet /configuration
STARTING file:./com.buglabs.bug.module-1.0.jar
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 Failed to start application bundle: /usr/share/java/apps/AccelerometerVisualizer.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/AccelerometerVisualizer.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/AccelerometerVisualizer.jar
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 AppManager checking /usr/share/java/apps/BasicCalculator.jar
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 Failed to start application bundle: /usr/share/java/apps/BasicCalculator.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/BasicCalculator.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/BasicCalculator.jar
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 AppManager checking /usr/share/java/apps/KnightRider.jar
Thu Jan 01 00:00:51 GMT 1970 Registered servlet /module
Thu Jan 01 00:00:51 GMT 1970 Registered servlet at /module.
Thu Jan 01 00:00:51 GMT 1970 Registered servlet /package
Thu Jan 01 00:00:51 GMT 1970 Registered servlet at /package.
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 Failed to start application bundle: /usr/share/java/apps/KnightRider.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/KnightRider.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/KnightRider.jar
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 AppManager checking /usr/share/java/apps/Puck.jar
STARTING file:./com.buglabs.bug.bmi-1.0.jar
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
 at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 Added modlet factory com.buglabs.bug.module.gps (0001) to map.
Thu Jan 01 00:00:51 GMT 1970 Added modlet factory com.buglabs.bug.module.camera (0005) to map.
Thu Jan 01 00:00:51 GMT 1970 Added modlet factory com.buglabs.bug.module.lcd (0003) to map.
Thu Jan 01 00:00:51 GMT 1970 Added modlet factory com.buglabs.bug.module.motion (0002) to map.
Thu Jan 01 00:00:51 GMT 1970 Added modlet factory com.buglabs.bug.module.vonhippel (0007) to map.
Thu Jan 01 00:00:51 GMT 1970 Creating pipe /tmp/eventpipe
Thu Jan 01 00:00:51 GMT 1970 Executing: /usr/bin/mkfifo /tmp/eventpipe
Thu Jan 01 00:00:51 GMT 1970 Failed to start application bundle: /usr/share/java/apps/Puck.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/Puck.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/Puck.jar
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 AppManager checking /usr/share/java/apps/InnovationLabTest.jar
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:51 GMT 1970 Execution Completed.  Response:
Thu Jan 01 00:00:51 GMT 1970 Failed to start application bundle: /usr/share/java/apps/InnovationLabTest.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/InnovationLabTest.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/InnovationLabTest.jar
Thu Jan 01 00:00:52 GMT 1970 Initializing existing modules
Thu Jan 01 00:00:52 GMT 1970 Executing: /bin/ls al /sys/devices/conn-m1/driver/module
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:52 GMT 1970 AppManager checking /usr/share/java/apps/InnovationLabGui.jar
Thu Jan 01 00:00:52 GMT 1970 Response: lrwxrwxrwx    1 root     root            0 Jan  1 00:00 /sys/devices/conn-m1/driver/module
> ../../../../module/bmi_lcd_core

Thu Jan 01 00:00:52 GMT 1970 Driver Name: bmi_lcd_core
Thu Jan 01 00:00:52 GMT 1970 Sending BMI ColdPlug message: 0003 0 0 ADD
Thu Jan 01 00:00:52 GMT 1970 Executing: /bin/ls al /sys/devices/conn-m2/driver/module
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:52 GMT 1970 Response: lrwxrwxrwx    1 root     root            0 Jan  1 00:00 /sys/devices/conn-m2/driver/module
> ../../../../module/bmi_mdacc

Thu Jan 01 00:00:52 GMT 1970 Driver Name: bmi_mdacc
Thu Jan 01 00:00:52 GMT 1970 Sending BMI ColdPlug message: 0002 0 1 ADD
Thu Jan 01 00:00:52 GMT 1970 Executing: /bin/ls al /sys/devices/conn-m3/driver/module
Thu Jan 01 00:00:52 GMT 1970 Failed to start application bundle: /usr/share/java/apps/InnovationLabGui.jar
        Exception: Not a valid bundle: file:/usr/share/java/apps/InnovationLabGui.jar
org.osgi.framework.BundleException: Not a valid bundle: file:/usr/share/java/apps/InnovationLabGui.jar
        at ch.ethz.iks.concierge.framework.BundleClassLoader.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.BundleImpl.<init>(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework.installNewBundle(Unknown Source)
        at ch.ethz.iks.concierge.framework.Framework$BundleContextImpl.installBundle(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.startApp(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.processQueue(Unknown Source)
        at com.buglabs.bug.program.UserAppManager.run(Unknown Source)
        at java.lang.Thread.startup(Unknown Source)
Thu Jan 01 00:00:52 GMT 1970 No module was found in slot 3
Thu Jan 01 00:00:52 GMT 1970 Executing: /bin/ls -al /sys/devices/conn-m4/driver/module
Thu Jan 01 00:00:52 GMT 1970 No module was found in slot 4
Thu Jan 01 00:00:52 GMT 1970 Registering existing module with message: 0003 0 0 ADD
Thu Jan 01 00:00:52 GMT 1970 processing: 0003 0 0 ADD
Thu Jan 01 00:00:52 GMT 1970 Creating modlet com.buglabs.bug.module.lcd
Thu Jan 01 00:00:52 GMT 1970 Setting up modlet com.buglabs.bug.module.lcd
LCDAccelerometer: Started
Thu Jan 01 00:00:52 GMT 1970 Started modlet from factory com.buglabs.bug.module.lcd…
Thu Jan 01 00:00:52 GMT 1970 Registering existing module with message: 0002 0 1 ADD
Thu Jan 01 00:00:52 GMT 1970 processing: 0002 0 1 ADD
Thu Jan 01 00:00:52 GMT 1970 Creating modlet com.buglabs.bug.module.motion
Thu Jan 01 00:00:52 GMT 1970 Setting up modlet com.buglabs.bug.module.motion
MotionRawFeed: Started
AccelerometerRawFeed: Started
Thu Jan 01 00:00:52 GMT 1970 Started modlet from factory com.buglabs.bug.module.motion…
Thu Jan 01 00:00:52 GMT 1970 Listening to event pipe. /tmp/eventpipe
STARTING file:./com.buglabs.bug.event-1.0.jar
Thu Jan 01 00:00:52 GMT 1970 Registered servlet /event
Thu Jan 01 00:00:52 GMT 1970 Registered servlet at /event.
STARTING file:./com.buglabs.bug.slp-1.0.jar
————————————————————————————

  Framework started in 16.254 seconds.
————————————————————————————-

Apr 21, 2009 11:10pm
Medium Bug Labs team kgilmer 215 posts

Hi Kenneth,

  Yes this problem is a result of mismatched versions between the SDK and BUG.  Please update your SDK to the testing build here and re-install your apps.  Another approach would be to upgrade your BUG from R1.3 to R1.4.

Apr 22, 2009 5:13am
User_img_not_found_03_med fiil123 14 posts

 

Hey

 

I have been trying to install the new version of the SDK but the install falls every time with this error:

 

An error occurred during provisioning.

Failed to prepare partial IU: [R]ch.ethz.iks.slp 1.0.0.RC1

 

Any ideas?

 

Apr 22, 2009 7:22am
Medium Bug Labs team kgilmer 215 posts

Hmmmf, Kenneth I have not seen that.  I’ll check around and see if anyone else has.  You might also try uninstalling the existing Dragonfly feature from Eclipse and installing the update fresh.  Unfortunately I don’t know much about the new Eclipse update facility in 3.4.

Apr 22, 2009 8:39am
User_img_not_found_03_med fiil123 14 posts

I have done a complete fresh update with a new downloaded version og eclipse but with the same error. Right know i’m trying to update the kernel and see if that helps

 

Apr 22, 2009 10:28am
Medium Bug Labs team bballantine 56 posts

Hi Kenneth,  thanks for your patience with this.  It seems like you had one problem, mismatched SDK + BUG version, and then another with the SDK update, which I haven’t seen before.  We are trying to get the new version of the SDK out rapidly which will resolve the mismatch issue, and uncovering this defect on the testing version will certainly help us.

Unfortunately I’m unable to reproduce the SDK issue on my own so I’m hoping you can provide a few details on how you came across this error.  First of all, what platform (Win, Mac, Linux) & version of that platform are you on?  Next, did you start with a clean install of Eclipse 3.4.2?  And in what step in the process did you see the error?  I would like to try to mimic your problem.

Also, here are jsut a few suggestions that might help:

# On the BUG, you can delete everything in /usr/share/java/apps and entirely remove the directory /usr/share/java/storage.  This will force the OSGi runtime to completely reset its state.

# ch.ethz.iks.slp is a package that allows the BUG to be discovered over a certain port on your computer.  It’s possible that the process has hung and it’s jamming things up.  Because of that, I recommend a reboot.

# After installing our plug in, Eclipse will ask to restart or apply changes.  Hit cancel and manually shut down and start eclipse.  Similar to the problem above, sometimes a restart doesn’t kill the SLP stuff properly and it can affect how the SDK works.

# Try a 1.1 full download for the time being (1.1.7, built on December 2nd ‘08 at buglabs.net/sdk).

# Jump on our IRC channel and ask me (bballantine) for help realtime debugging.   It’s good to have this stuff captured here, but sometimes the only way to solve the problem is in real-time.  Our IRC channel is #buglabs @ freenode.

Thanks,
Brian

Apr 23, 2009 11:14am
User_img_not_found_03_med fiil123 14 posts

Hey Brian

 Thanks a
lot for all the help, I have been a little busy lately therefore i have not
been able to respond earlier. About the IRC channel and due to the time difference
I will maybe have a hard time catching anybody in there.

 What I did
with the Eclipse thing was:

  1. Downloaded a new Eclipse
  2. Software updates
  3. Add site
  4. Install
  5. Downloading
  6. Installing

 And then
under the installation I got the Error. The machine was a Windows XP Service
Pack 2, I have tried it again on my own machine and I can’t reproduce it either.

Apr 23, 2009 12:30pm
Medium Bug Labs team bballantine 56 posts

fill123 –

I will ask our QA team if they can test things out on XP.  I don’t have access to that type of machine right now. 

I just have one more suggestions that that is a shot in the dark: Try to turn off any kind of firewall running on your machine, before installing the plugin.  The reason I suggest this is SLP might be trying to bind to port 1427 to look for devices. 

The best solution, in the end, is probably to upgrade your BUG to R1.4.  Then the latest production SDK will work.  We’re working on an update app which should be available in a week or so.  You can also do it manually if you have a linux machine by following the instructions here: http://bugcommunity.com/wiki/index.php/Upgradin…

Finally, next week we’re planning to release a new version of the SDK into production.  This will be compatible with both old and new BUGs and it will include a full download, which is Eclipse + Dragonfly pre-packaged.

I’ll respond here if we dig up anything new and if you have any more debug output, ideas, and whatnot, definitely post them here.

-Brian

Apr 24, 2009 2:50am
User_img_not_found_03_med fiil123 14 posts

 

Hey Guys

I just updated the kernel (and file system after finding a Linux machine with card reader:0)) and now everything is running smooth! Just made a little showcase on the office and people was really impressed and some almost off to ordering them their own BUG!

Cheers

 

Apr 24, 2009 3:49am
Medium Bug Labs team kgilmer 215 posts

That’s great to hear Kenneth!

Log in to reply to this topic
Forums Applications Application don't get downloaded to device