BUG Community

Welcome! Log In

Forums Applications Exporting to BugNet

Subscribe to Exporting to BugNet  7 posts, 4 voices

Log in to reply to this topic
 
Oct 3, 2007 11:30pm
Medium Bug Labs team finsprings 268 posts

Just a heads up that "Project/Send to BUGnet" won’t let you do it if you are compiling for Java 5 or 6; you have to go into your project (or workspace) setting for your compiler and crank it back to 1.4.

Oct 4, 2007 9:34am
Medium Bug Labs team mcholerton 54 posts

Hey finsprings – I saw your app up on Bugnet. The first beta user app! Fantastic.

Biking home last night over the Manhattan bridge I was thinking it would be cool to have a BUG mount on the bike, so the wifey could see what I saw – and how close I was to home. Camera, GPS, mash-up to Google maps, Flickr ….right? It looks like all our applications so far are bring us pretty close to BUG Bike View!

Oct 4, 2007 9:47am
Img_missing_medium hzaida 38 posts

Hi finsprings,

I believe this is related to an open defect we are currently working on.

When you received the java compiler 1.4 error, was this due to using (importing a project from BUGnet), editing, adding code of your own ‘then’ executing the export?

Please let me know.
Thank you in advance!

Oct 4, 2007 10:02am
Medium Bug Labs team finsprings 268 posts

I created a project from scratch using the wizard. Once I downgraded to 1.4 it let me export it okay.

Oct 4, 2007 12:21pm
Img_missing_medium hzaida 38 posts

Hi finsprings,

We have attempted to reproduce your issue and were not successful. Can you either post additional information (environment and steps to recreate) or enter a defect within Bugzilla? (fancy)

Thanks for your help on this one.

Oct 4, 2007 12:34pm
Medium Bug Labs team finsprings 268 posts

I was running Eclipse 3.3.1 on knoppmyth R5F27 (which is based on Debian Etch) with JDK 1.6_02.

I created a new workspace then created a new BUG project via File/New/Project/Dragonfly. I created all the classes via File/New/Class, but for some of them I cut-and-paste data in from FlickrUppr (which I had open in another instance of Eclipse in another workspace).

I had to hand edit the MANIFEST.MF to allow my bundle to run when I deployed it to the VirtualBUG – I was getting a classnotfound error that I’ve posted about previously. Once I did that I was able to run my bundle in VirtualBUG just fine.

I then tried to send it to BUGnet and it gave me an error dialog that read something like "must be compiled with 1.4". I went to my project settings (right-click on my project than properties than Java Compiler section inthe dialog) and overrode the workspace defaults to change the JDK Compliance to all be 1.4 instead of 6.0.

Once I did that I cleaned the project, redployed it to VirtualBUG and it stlil l ran okay. I then tried the Send to BUGnet again and it worked.

Hope that makes sense.