BUG Community

Welcome! Log In

Forums Applications Project Interdependencies: Unable to launch VirtualBug

Subscribe to Project Interdependencies: Unable to launch VirtualBug  5 posts, 4 voices

Log in to reply to this topic
 
Oct 1, 2007 9:23pm
Medium Bug Labs team finsprings 268 posts

I have all of the available applications downloaded into Eclipse. If I close any of their projects and then try to start The hotkey one, I get an error dialog that reads:

"
Unable to launch VirtualBug

Please consult log file for additional details.
"

I don’t know what log file it’s referring to.

It seems strange that the projects are interdependent. For example, why would Hotkey care if FlickrUppr was open or not?

I only decided to try this because I saw messages in the Eclipse Console from several of the service tracker objects, even though I thought I was only running one.

Oct 1, 2007 9:56pm
Medium Bug Labs team finsprings 268 posts

Here's a partial screengrab of FlickrUppr running on my 2.6.18 knoppmyth box on FluxBox:

You can see that the authentication entry box is off the side of the screen, so you can't enter the code. Also, the 'LCD' is title BUGWeather, which goes to my issue where all the apps seem to want to run together even when I only select one of them.

If i just right-click on FlickrUppr and select Run as VirtualBUG, the Eclipse Console shows the following. Is there a cache I need to clear out or something (I tried Build/Clean).

---------------------------------------------------------
Concierge OSGi 0.6.3 on Linux 2.6.18-chw-13 starting ...
---------------------------------------------------------
Logger initialized, loglevel is DEBUG
purging storage ...
INSTALLING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/cg_event.jar
INSTALLING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/cg_framework.jar
INSTALLING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/osgi.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/ch.ethz.iks.slp.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.base.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.event.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.menu.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.module.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.program.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.service.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.common.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.osgi.http.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/MenuExtender_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/LatLonConverter_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/LCDHelloworld_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/HotkeyTester_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/GoogleTiles_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/FlickrUppr_1.0.0.jar
INSTALLING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/BUGWeather_1.0.0.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.bmi.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.camera.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.gps.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.lcd.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.motion.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.slp.jar
INSTALLING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.osgi.shell.jar
STARTING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/cg_event.jar
STARTING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/cg_framework.jar
STARTING file:/home/dave/eclipse/configuration/org.eclipse.osgi/bundles/171/1/.cp/jars/osgi.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/ch.ethz.iks.slp.jar
[Mon Oct 01 21:50:34 EDT 2007] [DEBUG] jSLP OSGi started.
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Debug outputs disabled
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.base.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.event.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.menu.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.module.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.program.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.service.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.common.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.osgi.http.jar
[Mon Oct 01 21:50:34 EDT 2007] [INFO] HTTP Server waiting for connections...
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet /event
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet at /event.
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet /module
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet at /module.
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet /program
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet at /program.
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet /service
[Mon Oct 01 21:50:34 EDT 2007] [INFO] Registered servlet at /service.
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/MenuExtender_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/LatLonConverter_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/LCDHelloworld_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/HotkeyTester_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/GoogleTiles_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/FlickrUppr_1.0.0.jar
STARTING file:/home/dave/workspace/.metadata/.plugins/com.buglabs.osgi.concierge.runtime/bundles/BUGWeather_1.0.0.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.bmi.jar
[Mon Oct 01 21:50:35 EDT 2007] [INFO] Creating manager but no Pipe, due to being a virtual BUG.
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.jar
MenuExtenderServiceTracker: start
LCDHelloworldServiceTracker: start
Unable to allocate a screen region!
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.camera.jar
[Mon Oct 01 21:50:35 EDT 2007] [INFO] Added modlet factory com.buglabs.bug.module.camera (CAMERA) to map.
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.gps.jar
[Mon Oct 01 21:50:35 EDT 2007] [INFO] Added modlet factory com.buglabs.bug.emulator.modules.gps (GPS) to map.
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.lcd.jar
[Mon Oct 01 21:50:35 EDT 2007] [INFO] Added modlet factory com.buglabs.bug.emulator.module.lcd (LCD) to map.
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.emulator.module.motion.jar
[Mon Oct 01 21:50:35 EDT 2007] [INFO] Added modlet factory com.buglabs.bug.emulator.modules.motion (MOTION) to map.
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.bug.slp.jar
STARTING file:/home/dave/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.226/kernel/com.buglabs.osgi.shell.jar
---------------------------------------------------------
Framework started in 1.22 seconds.
---------------------------------------------------------

(:
Oct 2, 2007 1:13am
Img_missing_medium matt.gauger 15 posts

I’m having this problem on Mac OSX as well, where all downloaded apps have to be open. If I close one or more, I get that error message. Restarting Eclipse doesn’t seem to help, but deleting the project/app does seem to fix it.

Running all the apps (open projects) of course slows down the emulator. Most of the time I get Eclipse locking up (according to Mac OSX I can only Force Quit at that point)

Oct 2, 2007 11:07am
Medium Bug Labs team kgilmer 215 posts

Finsprings,

Regarding your original issue this is an issue we’ve duplicated in-house and will fix in the next release. In the meantime either run with all applications or use multiple workspaces to switch between Virtual BUG configurations.

Oct 2, 2007 1:28pm
Img_missing_medium hzaida 38 posts

Hi Finsprings,

Thank you for the information you provided, QA and DEV have been able to reproduce the same issue.

We have entered a defect on your behalf and can be found here:
http://bugbeta.com/bugzilla/show_bug.cgi?id=15

To answer your other question, here are the steps to access the log file referenced within the error message.

STR:
1. Go to Window > Show View > Other
2. Open PDE Runtime node
3. Select Error Log
4. Select OK
Expected Results: The associated log file is displayed within the Console view.

Thanks again!

Log in to reply to this topic
Forums Applications Project Interdependencies: Unable to launch VirtualBug

Powered by Community Engine