BUG Community

Welcome! Log In

Forums Applications FlickrUppr hanging for me on Mac OSX

Subscribe to FlickrUppr hanging for me on Mac OSX  32 posts, 11 voices

Log in to reply to this topic
 
Sep 25, 2007 10:26pm
Medium Bug Labs team finsprings 268 posts

I tried running FlickrUppr on Mac OSX 10.4.10 using JDK 1.5.0 and it hangs when I load the LCD module at the get frame line:
this.frame = disp.getFrame();

I tried it on XP in a VM with JDK 1.6.0_02 and it popped up its Flickr auth GUI just fine.

Anyone else seen this?

I’m also not keen on authorizing FlickrUppr on my Flickr account since it is asking for full access. Maybe I’ll set up a non-pro test account just for it. It would be nice if it just access for posting rights.

Sep 26, 2007 5:19am
Medium Bug Labs team kgilmer 215 posts

Hello finsprings, welcome to the BUG beta! To my knowledge we haven’t tested the FlickrUppr example app on OSX. We’ll take a look and let you know.

Sep 26, 2007 10:15am
Img_missing_medium aroman 21 posts

Hi Finsprings,

I have changed FlickrUppr’s permission to WRITE since it’s sufficient for now. Let me know if you find other issues.

Regards,
Angel

Sep 26, 2007 5:50pm
Medium Bug Labs team kgilmer 215 posts

We’ve reproduced your issue on OS X. Solution forthcoming in next SDK release.

Sep 26, 2007 6:33pm
Medium Bug Labs team mcaric 64 posts

Hi finsprings,

Your defect has been entered, you can view it here:

http://bugbeta.com/bugzilla/show_bug.cgi?id=14

Thanks again!
Melinda
Sep 26, 2007 10:25pm
Medium Bug Labs team finsprings 268 posts

Thanks! I would have opened it as a bug, but I wasn’t sure if it was just my setup. Glad you could reproduce it.

Now if we could just get Apple to give us 1.6 with a JIT….;-)

Sep 26, 2007 10:45pm
Img_missing_medium koolatron 52 posts

I get similar behavior under Linux.

Sep 27, 2007 12:05am
Medium Bug Labs team finsprings 268 posts

Any time frame on the release of the next SDK? Or is there a file I can pull from SVN to patch it for now?

I like to avoid my XP VM as much as possible ;-)

Sep 27, 2007 11:04am
Medium Bug Labs team bcruskie 45 posts

Hi koolatron,

Welcome to the BUG beta program! I was unable to reproduce this issue on my Linux box in the following environments:

Ubuntu release 7.04 (feisty)
Eclipse 3.2.2
Java 1.5_12

Ubuntu release 7.04 (feisty)
Eclipse 3.3
Java 1.5_12

Could you please post your Linux, Eclipse, and Java version?

Sep 27, 2007 1:20pm
Img_missing_medium hzaida 38 posts

Hi finsprings,

We are working on a schedule now. And… will have a new build very soon. Will keep you posted! Thank you for the inquiry.

Sep 27, 2007 1:59pm
Img_missing_medium koolatron 52 posts

Brian,

I’m encountering the same problem on both my Linux machines, wherein upon trying to start applications that use the LCD module the BUG hangs. Specifically, it creates the LCD output window and then becomes unresponsive. Here’s my setup:

(laptop):
Ubuntu release 7.04 (feisty)
`eclipse` package from feisty repos (provides Eclipse 3.2.2)
`sun-java6-jre` package from feisty-multiverse repos (I’m assuming this provides the right runtime environment for the BUG).

(desktop):
Ubuntu release 6.10 (edgy)
`eclipse` package from edgy repos (provides Eclipse 3.2.1)
`sun-java6-jre` package from edgy-backports.

Sep 27, 2007 5:04pm
Img_missing_medium koolatron 52 posts

OK, I remedied this on the laptop on my own. It seems that despite my having installed sun-java6-jre, Eclipse didn’t know about it or where to find it.

After pointing it to the right spot, I get better results; but since I’m not actually at my desktop at the moment I’ve yet to try it there with Eclipse 3.2.1.

Sep 28, 2007 9:37am
Medium Bug Labs team bcruskie 45 posts

That's good news Kool. I'm interested to see what the results are on 3.2.1.

We do recommend you upgrade Eclipse to 3.2.2 or 3.3: http://bugbeta.com/wiki/index.php/Installation_of_Eclipse_%26_Dragonfly_%28the_BUG_SDK%29#Install_Eclipse_Classic
Sep 28, 2007 11:06am
Img_missing_medium koolatron 52 posts

Besides the JRE hangup that I described (which is now resolved for both machines), Eclispe 3.2.1 and Dragonfly seem to be working without any problems.

Since there aren’t any (glaring) problems with the 3.2.1 setup, I’m going to leave it as-is for now. If I encounter problems that I can’t reproduce on 3.2.2 or 3.3, my first recourse will probably be to upgrade.

Oct 2, 2007 2:44pm
Medium Bug Labs team kgilmer 215 posts

Just an update to the original OS X/ LCD Module issue, we’re continuing to work through this. It turns out there are some compatibility issues between SWT and AWT that are causing a deadlock when we try to create an AWT frame in the LCD Modlet.

Oct 2, 2007 8:39pm
Img_missing_medium rbpasker 22 posts

Having the same new Frame() problem in LCDModlet.java:95 on OS/X 10.4.10, eclipse 3.3.0

if there’s a workaround, please let us know!

Oct 4, 2007 2:26pm
Medium Bug Labs team kgilmer 215 posts

At this point the only workaround is to use Linux or Windows (via parallels, etc) to write GUI apps. We were hoping there was some fix for this SWT/AWT issue but we’re not having much luck. Most likely we’ll have to re-implement the UI in AWT. We’ll keep you posted on our progress. One question, would a purely command-line driven Virtual BUG with LCD support be sufficient, or do people like the GUI Virtual BUG?

Oct 4, 2007 8:29pm
Img_missing_medium rbpasker 22 posts

i’ve written a pure AWT bug simulator, which can be found here.

warning! the graphics and layout are not very sophisticated, but it is completely serviceable.

It can handle the 2×4 buttons, adding/removing Modules from Slots, and has a Display canvas.

http://pastebin.com/d4a53f571

please feel free to replace the SWT version with this one;)

Oct 5, 2007 9:44am
Medium Bug Labs team kgilmer 215 posts

Bob, cool! We’ll take a look.

Oct 8, 2007 3:21pm
Img_missing_medium rbpasker 22 posts

http://pastebin.com/f5b06aa

i realize that I forgot the callback interface.

any progress on this?

thanks, bob

Oct 8, 2007 4:43pm
Img_missing_medium akravets 25 posts

Bob,

We are almost finished with the conversion to AWT, thanks for your contribution.

Alex Kravets, Bug Labs

Oct 8, 2007 5:03pm
Img_missing_medium rbpasker 22 posts

excellent—i’m happy to alpha test a new drop whenever its ready!

Oct 15, 2007 11:50am
Medium Bug Labs team kgilmer 215 posts

Hello ~

A console-based Virtual BUG has been uploaded to BUGnet. The app title is com.buglabs.bug.emulator.console and is available here: http://buglabs.net/application/show/10.

Basically, you use the command line to fire button events and connect modules rather than a GUI window. It's not going to win any beauty contests but it's functional. Here is a sample how to interact with it:

(: help
Command____Usage__________________________Description__________________________________________________________________
bmi_insert Module_id slot_id Insert a module into the running virtual BUG.
bmi_remove Module_id slot_id Remove a module into the running virtual BUG.
bundles [filter] Returns a list of bundles present in current OSGi runtime environment.
consumers [(bundle id | bundle name)]... Returns a list of services that each bundle consumes is currently consuming.
display Show the last message written to the display.
exit exit Stop all bundles and shutdown OSGi runtime.
headers bundleId [filter] Returns the headers for a given bundle.
help help [filter] Print table of currently available commands.
hk 1-4 Causes hotkey on Virtual BUG to be pressed.
install bundle_URL Install a bundle from the given URL.
nav (UP | DOWN | LEFT | RIGHT) Causes navigation button on Virtual BUG to be pressed.
printenv [filter] Returns the system settings.
producers [(bundle id | bundle name)]... Returns a list of services that each bundle is currently offering.
quit quit Stop the shell bundle.
restart Stop and restart all running bundles.
services [(bundle id | bundle name)]... Returns a list of services present in the runtime.
shutdown Shutdown runtime.
start (bundle_Id | bundle_name)... No help available for this command.
stop (bundle_Id | bundle_name)... No help available for this command.
update update Stop and restart all active bundles.

(: bmi_insert CAMERA 0
[Mon Oct 15 11:41:58 EDT 2007] [INFO] Created modlet from factory com.buglabs.bug.module.camera...
[Mon Oct 15 11:41:58 EDT 2007] [INFO] Received new INSERT m