BUG Community

Welcome! Log In

Forums Applications Problem with AWTTutorialForBug app

Subscribe to Problem with AWTTutorialForBug app  3 posts, 2 voices

Log in to reply to this topic
 
May 28, 2009 4:09pm
User_img_not_found_04_med millerdlca 4 posts

Hi, I’m new to Bug and just trying out the development tools and sample apps at this point. 

When I tried running AWTTutorialForBug in Eclipse it failed to start properly.  The first problem was that the startup would hang with a message “Connecting to: http:127.0.0.1:8082”.  This is a previously reported issue on Windows XP and can be worked around by entering a carriage return in the Console window (although it’s very irritating to have to do that on every run).

Virtual Bug would then start and the graphic window appears showing the BUGbase and the appropriate modules. However, the frame representing the BUGview screen never appeared.  After some investigation it became clear that it was never getting to the point of calling the doStart() method in AWTTutorialServiceTracker; canStart() was never becoming True.  Further investigation showed that one service never became available: “com.buglabs.bug.tests.common.IButtonController”.  This service is specified in the initServices() method so the startup couldn’t proceed.  I wasn’t able to find it used anywhere in the app so I removed the getSrevices().add( “com.buglabs.bug.tests.common.IButtonController”) statement from the initServices() method.  After doing this, the app runs properly.

I’m not sure why the service was being requested since it didn’t seem to be used, nor why nothing was providing it.  I assume the buttons being referred to by the Javadoc for this interface are the ones on the BUGbase, which would imply the base should provide the service, but maybe it means something different. Since the service wasn’t being used as far as I can see, I expect the app needs to be modified.

For the record, this was on Windows XP using Eclipse V3.4.2 build M20090211-1700 and Dragonfly 1.3.3.v200905151522_p

Dennis

May 28, 2009 5:28pm
Medium Bug Labs team jconnolly 285 posts

Comment on the app itself so Kevin has a chance to fix it.

May 28, 2009 11:51pm
User_img_not_found_04_med millerdlca 4 posts

Thanks, I didn’t realize I could do that.  I’ve copied my post over to the app comments.

Dennis

Log in to reply to this topic
Forums Applications Problem with AWTTutorialForBug app

Powered by Community Engine