BUG Community

Welcome! Log In

Forums BUG SDK BUG doesn't show up in Dragonfly

Subscribe to BUG doesn't show up in Dragonfly  2 posts, 1 voice

Log in to reply to this topic
 
May 23, 2009 11:03pm
User_img_not_found_04_med syriven 7 posts

I got my BUG in the mail a few days ago, and have been tentatively playing around with it. Since I’m vaguely familiar at best with a lot of what BUG uses (Java, eclipse/dragonfly, ssh), the going has been slow. So it could be I’m missing something. But anyway, when I plug the BUG into my computer, turn the BUG on, and start Eclipse/Dragonfly, it no longer shows up in Dragonfly’s “My BUGs” window. However, I can still connect to the BUG via ssh.

I can’t think of what would have caused this, but I’ve tried restarting the bug, restarting the computer, and plugging the BUG into a different USB port on my computer (which caused me to reinstall the driver, which didn’t help either).

Right now I’m downloading a fresh install of Eclipse, and will update to the latest Dragonfly, to see if that works. I’m posting this while I’m waiting; I figured that if this does fix it, this post will be here so others who have the same problem will know how to fix it.

May 24, 2009 1:01am
User_img_not_found_04_med syriven 7 posts

Well, I signed on to IRC and asked finsprings for help. We worked on it for somewhere between 30 minutes and an hour, using ssh, and finally we discovered that a program I had been messing around with was closing the java VM when it should have just been closing itself down.

I had read that you shouldn’t use System.exit(0), because it will shutdown the whole java VM, but I guess I had that command in there from earlier and forgot to take it out. I changed System.exit(0) to a simple break, and that fixed it.

So that’s that. For the record, finsprings was incredibly helpful throughout the whole process.

Log in to reply to this topic
Forums BUG SDK BUG doesn't show up in Dragonfly

Powered by Community Engine

Top
Login
Close
Bottom