BUG Community

Welcome! Log In

Forums BUG SDK SDK Under Linux?

Subscribe to SDK Under Linux?  21 posts, 5 voices

Log in to reply to this topic
Oct 6, 2007 3:18pm
Img_missing_medium daryll 11 posts

I’ve been struggling getting the SDK running under Linux. I suspect the Fedora packaging is making it difficult to use the eclipse update mechanism.

I was running Fedora 7, but since you said you wanted Europa and I wanted to try Fedora 8 anyway, I went ahead and upgraded to the Fedora 8 test 3 release.

Fedora 8 includes:
Eclipse Europa

So the first couple steps of your install are satisfied with RPM packages. Then your instructions say to install graphical editing framework. If I follow your instructions I get back a message from Eclipse saying that the resulting configuration does not contain the package. But Fedora has a eclipse-gef RPM. That installs just fine.

Now, I’m trying to install dragonfly. I get the same message about the resulting configuration not containing the package. My guess at this point is that the RPM packages get the Eclipse packages installed, but somehow Eclipse doesn’t know that for solving it’s own dependency requirements.

At this point I’m stuck. Any suggestions? Is there a way to manually install the SDK instead of using eclipse to do it?

Oct 6, 2007 7:50pm
Medium Bug Labs team finsprings 268 posts

I had this same problem on Linux. I farted around trying to get it to manually install GEF but it still wouldn’t recognize it (even though I could plainly see the correct jars in the plugins directory).

I ended up trying the auto-install again, but that time I unchecked the ‘auto-select mirror’ (or however it’s worded). I picked one from further down the list – don’t remember which, sorry – and hey presto it had GEF just like it showed up on Windows and Mac.

Very annoying I agree. Maybe try a few other mirrors and see if you can find it.

Oct 7, 2007 2:31pm
Img_missing_medium daryll 11 posts

We’re making some progress.

I turned off the automatically pick mirror option. The first site in my list was Georgia State, and that worked when I installed GEF and then the bug SDK worked fine.

It looks like the RPM installs the framework in the system area, so everyone on the system can use it. Installing it via the upgrade mechanism installs it in my local directory. It also appears the dependency checking doesn’t really understand both locations.

That got me over the first hurdle. Now I’ve got it loaded, but when I select window…open perspective…other… dragonfly isn’t listed.

The only other thing I could think of was the java version so I’ve tried gcj v1.5, Sun JDK 1.6, and IcedTea 1.7. But none of those made any difference. So I must be missing something, but I don’t see any error messages indicating what.

Anyone have additional ideas?

Oct 7, 2007 4:09pm
Medium Bug Labs team finsprings 268 posts

Did you run the install step for Dragonfly atfer you successfully got GEF in there?

Oct 7, 2007 5:01pm
Img_missing_medium daryll 11 posts

Yep, I added buglabs.net’s site.
It showed me the dragonfly SDK.
I checked the box, and it had the platform. No problem there.
Then I did the install, it downloaded a bunch of stuff, prompted me for the license, and finished up. Then it told me eclipse had to restart.
So it seems to have installed OK.

Just no dragonfly option when I change to the perspective…other… choice.

Oct 8, 2007 7:17am
Medium Bug Labs team kgilmer 215 posts


Sorry to hear you’ve been having troubles getting the SDK running. GCJ is known not to work with Eclipse. We typically get Java 1.5 from Sun. Some questions:

1. If you go to Help -> About Eclipse SDK do you see the Dragonfly SDK icon?

2. Go to Window > Show View > Other, select "PDE Runtime -> Error Log", click the red "X" in the Error Log view to clear the log. Restart Eclipse and paste in this thread any errors you get.

Oct 10, 2007 1:59am
Img_missing_medium daryll 11 posts

I found the install.log and it says:

!CONFIGURATION 1191892155425 Mon Oct 08 18:09:15 PDT 2007
!ACTIVITY 1191892150204 Oct 08, 2007 18:09:10.204 com.buglabs.dragonfly.feature_ feature-install success
!ACTIVITY 1191892155389 Oct 08, 2007 18:09:15.389 com.buglabs.dragonfly.feature_ feature-enable success

Then I went into the manage configuration, and I found the dragonfly plugin. I can see the properties. I clicked the disable button and then enabled it again, which added the following to entries in the install.log:

!CONFIGURATION 1191994955651 Tue Oct 09 22:42:35 PDT 2007
!ACTIVITY 1191994955607 Oct 09, 2007 22:42:35.607 com.buglabs.dragonfly.feature_ feature-disable success

!CONFIGURATION 1191995116389 Tue Oct 09 22:45:16 PDT 2007
!ACTIVITY 1191995116340 Oct 09, 2007 22:45:16.340 com.buglabs.dragonfly.feature_ feature-enable success

So it looks like dragonfly installed correctly. I just don’t get the perspective choice. Is there some other debugging output I can look at? Nothing interesting shows up with -consolelog -debug.

Any suggestions?

Oct 10, 2007 11:20pm
Medium Bug Labs team kgilmer 215 posts


Are you sure you installed GEF from the Eclipse update site? The SDK plugins will not run without these plugins. If you go to your eclipse install and type:

ls plugins | grep -i gef

What do you see?
Oct 10, 2007 11:35pm
Img_missing_medium daryll 11 posts

It seemed to install GEF:

Here’s the ls output you asked for:


Very strange, eh?

Oct 11, 2007 9:03am
Medium Bug Labs team kgilmer 215 posts

Yes Daryll, very strange :) . Can you take a look at the PDE error log? I find it best to clear out the log and restart Eclipse to avoid sorting through old errors. To enable the view go in Eclipse to Window > Show View > Other… and select PDE Runtime -> Error Log. Clear the log and restart Eclipse. Please check if there are any errors after restarting Eclipse

Oct 12, 2007 1:24am
Img_missing_medium daryll 11 posts

The only error I see on startup after clearing the log is:

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

Thu Oct 11 08:58:45 PDT 2007
Could not install bundle plugins/org.eclipse.pde.build_3.3.0.v20070612/ Bundle "org.eclipse.pde.build" version "3.3.0.v20070612" has already been installed from: update@plugins/org.eclipse.pde.build/

I did install all the PDE packages I saw in the distro, and I think that caused this to show up.

What’s our next step coach?

- |Daryll

Oct 12, 2007 8:45am
Medium Bug Labs team kgilmer 215 posts


If you now try to switch to the Dragonfly perspective and it doesn’t work, another error should appear in the PDE error log. Is so please send that back to me. Also, from the log it looks like you are running Java 1.7. I do not know if this is related to your issue but we do not test against 1.7 at this time and recommend 1.5. Is it possible for you to launch Eclipse with 1.5?

Oct 12, 2007 10:39am
Img_missing_medium daryll 11 posts

That’s the thing. There is no dragonfly perspective. If I select Other… the list includes:

CVS Repository Exploring
Java Browsing
Java Type Hierarchy
Resource (default)
Team Synchronizing

- |Daryll

Oct 15, 2007 9:00am
Medium Bug Labs team kgilmer 215 posts


Very strange. I’ve gone through all the simple steps I can think of… Ideas anyone else? We have only tested on Ubuntu so I’m not sure if this is a FC issue or an Eclipse issue. I can talk with our QA team about testing FC but in the short term is there a way for me to take a look via VNC or some other remote control software?

Oct 17, 2007 7:40pm
Img_missing_medium daryll 11 posts

I installed the pure Eclipse Eudora and installed the packages and that doesn’t work either.

I also noticed that I don’t have the PDE perspective in either Fedora Eclipse or Eclipse Eudora. That’s independent of trying to install bug.

I suspect the problem is either in F8 or specific to my laptop. (how much fun would that be?)

I’ve got some of the Red Hat guys saying they’re going to install F8 and try Eclipse, so that should help narrow down the problem.

I don’t think it’s worth you doing tracking it any further unless I get the PDE stuff working. I’ll let you know how it goes.

- |Daryll

Oct 17, 2007 9:19pm
Img_missing_medium tomeast 1 post

I had the exact same symptoms you describe:
no option to even select the dragonfly perspective

I also noticed that I didn’t have the PDE error log option so I went in and installed the Eclipse Plugin development environment using help->software updates->find and install->search for new features->Europa Discovery site

After Eclipse restarted I now have the option to open the Dragonfly perspective. Great!

I should note that I am on Kubuntu. However I did try on a second Kubuntu box at work where I was able to open the Dragonfly perspective fine.

Oct 17, 2007 9:54pm
Img_missing_medium Shawn 14 posts

I have a bunch of different development needs, so I thought I would try to build a Vmplayer Ubuntu vmimage and load it up. It all worked for me so here is the steps in-case it helps others.

Ubuntu 7.04
1g> ram
- 4G free drive space (~3.2g to build the Vmimage in)

Needed files:
vmplayer 2.0.1
Ubuntu vm image http://chrysaor.info/?page=ubuntu
(i’ll be building my own tomorrow when 7.10 come out)
eclipse 3.3 europa
- java jdk1.6 update 3

1) installed new vmplayer (had 2.0.0, did reinstall of 2.0.1)
2) booted vm image logged in as user
3) updated vm OS from update prompter (something like 12 files) (would suggest just getting the ubuntu cd image and doing a custom install that way you can leave out openoffice and other tools you don’t need)
4) copied JDK and Eclipse install files to vm image
5) installed JDK
6) setup JAVA_HOME and PATH in .profile on vm OS and relogged in
7) verified java 1.6 was found $> java -version
8) untarred eclipse to user directory
9) started eclipse and updated GEF (wiki says 3.3.0 but 3.3.1 is now there)
10) restarted Eclipse from dialog (as stated in wiki)
11) installed dragonfly SDK as stated in wiki
12) restarted Eclipse again.

Everything worked. whoo, and finished without a step 13. ;)

This ubuntu vm image with everything installed takes 2.9G (ouch)
and that was after I pruned some of it back using filelight to see where the space was.



Oct 18, 2007 12:25pm
Img_missing_medium daryll 11 posts

Once I realized that the PDE wasn’t initializing correctly, I worked with the Red Hat guys.

I ended up removing every package related to java. Then installed it all again. Now everything is coming up cleanly.

The other good news is that F8 seems to have everything you need for bug. Java-1.7-icedtea, eclipse eudora, packages for PDE and GEF. All those can be installed as RPMs, then the bug SDK installs just as you listed.

So I’m up and running, and will get started on some projects now!

Oct 18, 2007 5:44pm
Medium Bug Labs team kgilmer 215 posts


Nice work! Is there a RH forum thread or something we could point other fedora users to if they have the same issue?

Oct 18, 2007 9:14pm
Img_missing_medium daryll 11 posts

Not really. There’s a bug report at Red Hat. But it goes through the same thing as this thread. When it became clear that PDE wasn’t initializing correctly even though I removed and installed eclipse, that was easy for them to reproduce. They installed F8 and said it worked fine. At that point I realized it must be something else java related and applied a big hammer of removing everything java related and reinstalling.


Oct 19, 2007 8:34am
Medium Bug Labs team kgilmer 215 posts

Got it. Thanks Daryll.


Log in to reply to this topic
Forums BUG SDK SDK Under Linux?

Powered by Community Engine